Mazda Wheel locks

Tire and Wheel Discussion
Huzer21

Postby Huzer21 » Sat Jun 07, 2008 9:14

So I go to finally swap on my EBC pads today. First wheel lock...stripped. can't get the lock to stay on and turn at all. I try the other 3 wheels, it works ok on those. So...I go ahead and hammer a socket onto the wheel lock and get it off. I took the other locks off and swapped with the standard lugs. The locks suck!!

Swapped out the pads with no issues once I got the wheels off.

User avatar
dommo_g
Senior Member
Posts: 1089
Joined: Sun Sep 23, 2007 9:14
Location: Henderson
Contact:

Postby dommo_g » Sat Jun 07, 2008 9:14

Were these the locks that have the smooth shaft with the flower type pattern on the top, or are they a splined shaft? I have the smooth shaft type that came from a RX-8. I haven't tried to take them off recently so I hope they aren't fucked.

User avatar
GR-8
Posts: 5335
Joined: Thu Oct 11, 2007 9:14
Location: Denver/ Lakewood
Contact:

Postby GR-8 » Sat Jun 07, 2008 9:14

It's the smooth one. Mine have had no prob yet. Knock on Wood.

When my mom got tires on a few years ago the guys at discount (probably woulda happened to anyone) when they were taking the wheels off broke the actual lock socket peice. The "flower" shape peice came out of the socket and stayed on the lug. It worked good for 13 years.
Image

ImageImage

MazdaTom
Posts: 2191
Joined: Fri Sep 21, 2007 9:14
Location: Highlands Ranch
Contact:

Postby MazdaTom » Sat Jun 07, 2008 9:14

I had to drill the stud on my '91 626 after the lock-lug stripped. Never did replace that stud either. 4 out of 5 studs is good enough, right? Worked for about 50,000 miles for me.
[SIGPIC][/SIGPIC]
1997 Explorer XLT - 4.0 SOHC V6 Controltrac 4x4
mods- 30" BFGs, AAL + TT = 1.5" lift, more to come

User avatar
dommo_g
Senior Member
Posts: 1089
Joined: Sun Sep 23, 2007 9:14
Location: Henderson
Contact:

Postby dommo_g » Sat Jun 07, 2008 9:14

<div class='quotetop'>QUOTE (Greek8 @ Jun 7 2008, 06:03 PM) [url=index.php?act=findpost&pid=50822]<{POST_SNAPBACK}>[/url]</div>
It's the smooth one. Mine have had no prob yet. Knock on Wood.

When my mom got tires on a few years ago the guys at discount (probably woulda happened to anyone) when they were taking the wheels off broke the actual lock socket peice. The "flower" shape peice came out of the socket and stayed on the lug. It worked good for 13 years.[/b]


LOL...13 years...that might explain why it finally gave out. The only trouble I've ever had was with the 'tuner' type lugs that used to come with a lot of wheels a few years ago. The ones with the open face, and you took them off with a big hex key type adapter. They would get wet inside and rust the nut to the lug.

Huzer21

Postby Huzer21 » Mon Jun 09, 2008 9:14

As already mentioned, they're the "flower" style locks. Only 1 would not work, but I'm not going to carry a 19mm 12 pt socket and a hammer with me in the car in case something happens on the road with the other 3 locks. (not that RX8's have a spare tire or anything) Just wanted to post the topic as a heads up to those that haven't tried to remove their locks in a while. Rather be surprised in the driveway than on the side of the road!


Return to “Tires and Wheels”

Who is online

Users browsing this forum: No registered users and 9 guests